Jump to content

Garmin Fishfinder


nargse1

Recommended Posts

i bought a garmin 140 for my kayak end of last year and finally got round to installing it last week. all worked fine then today i turned it on again and only got a "sonar failure" coming up.

it hasnt been tested on the water yet but seeing it worked the 1st time i tried it and got into the menus etc, now its not letting me do anything but displaying the "sonar failure" on the screen.

i spoke to Garmin and the are puzzled too. said try it on the water and call back. i will be taking it out this weekend more than likely sunday.

has anyone had this problem or heard of this????

Link to comment
Share on other sites

Hi Mate,

I recently installed the FF140 my second one over two boats, never had a problem with them....until recently. I did get the sonar failure issue, the only thing I could find wrong was the connection had not be screwed up correctly (my fault) & when entering the boat I had accidently kicked the transducer up.

I don't know if that would help you mate, but turn the power off & unscrew it from the back of the finder unit you might want to give it a quick spray with contact cleaner if you want to be extra certain. then carefully screw it back together.

I don't know if that will be of any use to you mate.

Cheers

Jas

Link to comment
Share on other sites

I had the same prob after about 18 months. It seems to be a connection issue as when I retightened the screw-in connection it was OK. I had another problem and the screen kept fading but once again, the problem may have been a connection or salt in the plug.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...