Jump to content

motorguide problem


Recommended Posts

Hi guys,

I was using my trolling motor - motorguide 55sw - last week, was good for half a day then it started vibrating badly and lost all propulsion power. It still steered left and right. I charged the deep cycle over the weekend (thinking it may be low battery) with the ctek and the battery is all good, connected up the motorguide this morning and still no propulsion power.

It still turns to the left and to the right, however no propulsion. When I the prop a little spin it started up for a couple of seconds with the vibration then died again. I used a multimeter on the battery and got dad to spin it it started up for a few seconds again with the vibration then died. I did not see any massive power drop in the voltage of the battery in this instance. The battery was replaced April last year and seems fine to me.

I then used the ctek on supply mode to power up the motorguide and still no propulsion. I unclipped it from the boat and took it to Penrith where I bought my boat and motorguide (2009). I wont have any warranty left as it was two years but asked the mech to check to see whats wrong with the motorguide, I should know by next week hopefully.

So I am wanting to know if anyone using a motorguide has had this issue. Ive herd of a few instances where the steering malfunctioned but not the propulsion.

Would loved to have been told today by the mech that it is stuffed and need new in which case I would just go buy another one this week, but he is unsure himself.

Any help would be greatly appreciated, even if it is "yes ive had this problem and the motor is stuffed, go buy a new one".



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...